wnpa-sec-2011-15 · Wireshark Lua script execution vulnerability


Name: Wireshark Lua script execution vulnerability

Docid: wnpa-sec-2011-15

Date: September 7, 2011

Affected versions: 1.6.0 to 1.6.1, 1.4.0 to 1.4.8

Fixed versions: 1.6.2, 1.4.9

References: Bug 6136



Wireshark could run arbitrary Lua scripts.


It may be possible to make Wireshark run arbitrary code using a method similar to DLL hijacking.


Upgrade to Wireshark 1.6.2, 1.4.9 or later.

Go Beyond with Riverbed Technology

Riverbed is Wireshark's primary sponsor and provides our funding. They also make great products that fully integrate with Wireshark.

I have a lot of traffic...

ANSWER: SteelCentral™ AppResponse 11
  • • Full stack analysis – from packets to pages
  • • Rich performance metrics & pre-defined insights for fast problem identification/resolution
  • • Modular, flexible solution for deeply-analyzing network & application performance
Learn More