wnpa-sec-2010-14 · LDSS and ZigBee ZCL vulnerabilities in Wireshark


Name: LDSS and ZigBee ZCL vulnerabilities in Wireshark

Docid: wnpa-sec-2010-14

Date: November 18, 2010

Affected versions: {{ start_version }}

Fixed versions: 1.4.2

Related: wnpa-sec-2010-13 (LDSS vulnerability in Wireshark version 1.2.0 to 1.2.12 )



Wireshark 1.4.2 fixes the following vulnerability:

  • Nephi Johnson of BreakingPoint discovered that the LDSS dissector could overflow a buffer. (Bug 5318) Versions affected: 1.2.0 to 1.2.12 and 1.4.0 to 1.4.1. CVE-2010-4300
  • The ZigBee ZCL dissector could go into an infinite loop. (Bug 5303) Versions affected: 1.4.0 to 1.4.1. CVE-2010-4301


It may be possible to make Wireshark crash by injecting a series of malformed packets onto the wire or by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.4.2 or later.

If are running Wireshark 1.4.1 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the LDSS and ZigBee ZCL dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "LDSS" and "ZigBee ZCL" are un-checked.
    • Click "Save", then click "OK".
Go Beyond with Riverbed Technology

Riverbed is Wireshark's primary sponsor and provides our funding. They also make great products that fully integrate with Wireshark.

I have a lot of traffic...

ANSWER: SteelCentral™ AppResponse 11
  • • Full stack analysis – from packets to pages
  • • Rich performance metrics & pre-defined insights for fast problem identification/resolution
  • • Modular, flexible solution for deeply-analyzing network & application performance
Learn More