wnpa-sec-2009-03 · PCNFSD vulnerability in Wireshark


Name: PCNFSD vulnerability in Wireshark

Docid: wnpa-sec-2009-03

Date: May 21, 2009

Affected versions: {{ start_version }} up to and including {{ end_version }}

Fixed versions: 1.0.8



Wireshark 1.0.8 fixes the following vulnerability:

  • The PCNFSD dissector could crash. Versions affected: 0.8.20 to 1.0.7


It may be possible to make Wireshark crash remotely or by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.0.8 or later.

If are running Wireshark 1.0.7 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the PCNFSD dissector:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "PCNFSD" is un-checked.
    • Click "Save", then click "OK".
Go Beyond with Riverbed Technology

Riverbed is Wireshark's primary sponsor and provides our funding. They also make great products that fully integrate with Wireshark.

I have a lot of traffic...

ANSWER: SteelCentral™ AppResponse 11
  • • Full stack analysis – from packets to pages
  • • Rich performance metrics & pre-defined insights for fast problem identification/resolution
  • • Modular, flexible solution for deeply-analyzing network & application performance
Learn More