https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7391
--- Comment #9 from Pascal Quantin <pascal.quantin@xxxxxxxxx> 2012-06-22 06:07:11 PDT ---
(In reply to comment #8)
> Generally I really like idea to have same name for similar fields.
> And we need general fix not only for bootp, IMHO option 5 from bug #2402
> comment 1 would be best one.
+1 but I guess it will take some time to achieve it (and might not be
backported to trunk-1.8)
> And users will hate us when he or she need to type: bootp.option.value_int8 ==
> 04 || bootp.option.value_int16 == 04 || bootp.option.value_int32 == 04 ||
> bootp.option.value_uint8 == 04 ... :)
Agreed. That's why I was thinking about also putting back the old filter as an
hidden one so that it can still use the filter from 1.6 (ugly, I know...)
@@ -1514,6 +1514,10 @@
tvb, voff, consumed, code, "(%d) %s", code, opt->text);
v_tree = proto_item_add_subtree(vti, ett_bootp_option);
proto_tree_add_item(v_tree, hf_bootp_option_length, tvb, voff+1, 1,
ENC_BIG_ENDIAN);
+ if (optlen > 0) {
+ ti = proto_tree_add_item(v_tree, hf_bootp_option_value, tvb, voff+2,
optlen, FALSE);
+ PROTO_ITEM_SET_HIDDEN(ti);
+ }
Concerning the comparison functions, I need to have a look for this int vs uint
thing.
--
Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.